Remote Browser Isolation Service - Un-available in Ashburn Region

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 12:26 UTC

Monitoring

Customer Impact: RBI services are currently un-available in Ashburn (us-east-1) region. Our automated load balancing mechanism has re-routed traffic to an alternate cluster to ensure continuity of services.

Description: We have identified the problem and a fix has been deployed. We continue to monitor the service for stability.
Posted Jul 10, 2025 - 12:05 UTC

Investigating

Customer Impact: RBI services are currently un-available in Ashburn (us-east-1) region. Our automated load balancing mechanism has re-routed traffic to an alternate cluster to ensure continuity of services.

Description: We are currently experiencing problem with our RBI data-plane in Ashburn region. Traffic has automatically been re-routed to another region while we work on remediating the problem.

Next update time: 09:00 AM UTC
Posted Jul 10, 2025 - 08:01 UTC
This incident affected: Data Centers and PoP (N. Virginia (us-east-1)).