Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Logging in to the portal may succeed after several retries, and customers may experience higher latency during the login process. Our investigation has also identified that this incident may have affected some RBI customers, who may have required new authentication tokens from IDM.
Current Status & Next Steps: Services have remained stable for the last 2 hours. We continue to investigate the root cause and monitor services closely.
Posted Mar 09, 2026 - 20:12 UTC
Update
Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Logging in to the portal may succeed after several retries, and customers may experience higher latency during the login process. Our investigation has also identified that this incident may have affected some RBI customers, who may have required new authentication tokens from IDM.
Description: Services have remained stable for the last 50 minutes. We continue to investigate the root cause and monitor services closely. We continue to treat this incident as a priority, and teams are engaged in the troubleshooting process.
Posted Mar 09, 2026 - 18:55 UTC
Update
Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Logging in to the portal may succeed after several retries, and customers may experience higher latency during the login process. Our investigation has also identified that this incident may have affected some RBI customers, who may have required new authentication tokens from IDM.
Description: Services have remained stable for the last 50 minutes. We continue to investigate the root cause and monitor services closely. We continue to treat this incident as a priority, and teams are engaged in the troubleshooting process.
Posted Mar 09, 2026 - 18:49 UTC
Update
Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Login to the portal maybe successful after several retries, and customers may experience elevated latency during the login process. Our investigation has also identified that this incident may have impacted some of RBI customers who may have required fresh authentication tokens from IDM.
Description: After a period of stability, services have started to experience failure in the last 5 minutes. We continue to treat this incident as a priority and teams are engaged in the troubleshooting process.
Next update time: 18:30 UTC
Posted Mar 09, 2026 - 17:28 UTC
Update
Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Login to the portal maybe successful after several retries, and customers may experience elevated latency during the login process. Our investigation has also identified that this incident may have impacted some of RBI customers who may have required fresh authentication tokens from IDM.
Description: We continue to see stability for the last 53 minutes, and customers should be able to access DSC Portal, Insights and browse via RBI. However we continue to investigate the problem and closely monitor our services. We will provide further updates as we learn more about the situation.
Next update time: 17:30 UTC
Posted Mar 09, 2026 - 16:37 UTC
Update
Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Login to the portal maybe successful after several retries, and customers may experience elevated latency during the login process. Our investigation has also identified that this incident may have impacted some of RBI customers who may have required fresh authentication tokens from IDM.
Description: We continue to investigate the problem and will provide further update as we make progress.
Next update time: 17:00 UTC
Posted Mar 09, 2026 - 16:10 UTC
Investigating
Customer Impact: Customers may experience issues accessing Forcepoint's Data Security Cloud Platform and Insights. Login to the portal maybe successful after several retries, and customers may experience elevated latency during the login process.
Description: We are currently experiencing a problem impacting accessibility of our Data Security Cloud Platform. Teams are investigating and will provide updates as soon we make progress.
Next update time: 16:00 UTC
Posted Mar 09, 2026 - 15:27 UTC
This incident affected: Management Console (Unified Platform), Services (Remote Browser Isolation), and Supporting Service (Insights).