Customer Impact: We have identified a similar degradation impacting Phoenix (us-west-2) region as well. Customers in Northern Virginia (us-east-1) region and Phoenix (us-west-2) will unable to browse via RBI.
Current Status & Next Steps: We have implemented the necessary remediation to restore the health of impacted services in both the regions and traffic has been re-introduced to the Ashburn (us-east-1).
We are currently monitoring our environment for stability, and will provide a final update once we have confirmation on the same.
Next update time: 17:00 UTC
Posted Apr 03, 2026 - 16:25 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 03, 2026 - 14:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 03, 2026 - 13:58 UTC
Identified
Customer Impact: We have identified a similar degradation impacting Phoenix (us-west-2) region as well. Customers in Northern Virginia (us-east-1) region and Phoenix (us-west-2) will unable to browse via RBI.
Description: We have identified a workaround and working on deploying a fix. We will provide further updates as we make progress.
Next update time: 14:30 UTC
Posted Apr 03, 2026 - 13:48 UTC
Investigating
Customer Impact: Some of our RBI customers may have experienced a brief loss of connectivity while browsing from North Virginia (us-east-1) region until services were failed over to an alternate cluster.
Description: We are currently experiencing un-availability of RBI services in the North Virginia region. We have rerouted customer traffic to an alternate region to mitigate impact. Teams are troubleshooting the incident, and we will provide further update as we make progress.
Next update time: 13:30 UTC
Posted Apr 03, 2026 - 11:51 UTC
This incident affected: Data Centers and PoP (N. Virginia (us-east-1), Oregon (us-west-2)) and Services (Remote Browser Isolation).