Customer Impact: Some of our Cloud Web Security customers may experience a certificate error while accessing a few web pages from our Cloud web solution.
Description: We have identified the problem where our Cloud Web proxy solution is unable to correctly validate a certificate chain presented by the impacted websites. We have developed a fix and are currently working on performing a thorough validation before the fix is rolled out across our production fleet.
Posted Jun 02, 2026 - 12:48 UTC
Update
Customer Impact: Some of our Cloud Web Security customers may experience a certificate error while accessing a few web pages from our Cloud web solution.
Description: We have identified the problem where our Cloud Web proxy solution is unable to correctly validate a certificate chain presented by the impacted websites. We continue to investigate the root cause further and will revert as soon as we have a remediation plan identified.
Posted Jun 02, 2026 - 05:53 UTC
Identified
Customer Impact: Some of our Cloud Web Security customers may experience a certificate error while accessing a few web pages from our Cloud web solution.
Description: We have identified the problem related to a third-party certificate authority certificate chain which are being used by the affected websites. We continue to investigate this further and will provide an update as we make progress.
Posted Jun 01, 2026 - 16:41 UTC
Investigating
Customer Impact: Some of our Cloud Web Security customers may experience a certificate error while accessing a few web pages from our Cloud web solution.
Description: We are currently investigating a problem which is triggering a certificate error for some of our customers while accessing certain web pages. We will provide further update as we make progress with our investigation.
Next update time: 16:30 UTC
Posted Jun 01, 2026 - 15:18 UTC
This incident affects: Services (Web Security Cloud).