Customer Impact: Some customers may have experienced a brief impact when the Web Security traffic for the Dubai DXBA datacenter failed over to a redundant data center.
Current Status & Next Steps: We have implemented the necessary remediation to restore the health of impacted services and traffic has been automatically re-introduced to the Dubai (DXBA) Datacenter
We are currently monitoring our environment for stability, and will provide a final update once we have confirmation on the same.
Next update time: 11:30 UTC
Posted Jul 14, 2026 - 10:35 UTC
Identified
Customer Impact: Some customers may have experienced a brief impact when the Web Security traffic for the Dubai DXBA datacenter failed over to a redundant data center.
Current Status & Next Steps: We have identified the problem to be related to degraded performance. We continue to actively work towards a resolution.
Next update time: 11:00 UTC
Posted Jul 14, 2026 - 10:07 UTC
Update
Customer Impact: Some customers may have experienced a brief impact when the Web Security traffic for the Dubai DXBA datacenter failed over to a redundant data center.
Description: We are currently investigating the issue causing higher latency in Dubai cluster DXBA datacenter. We will provide an update as we make progress.
Next update time: 09:30 UTC
Posted Jul 14, 2026 - 08:43 UTC
Investigating
Customer Impact: Web Security cloud customers may have observed a increased response times for a brief period.
Description: We are currently experiencing latency high performance in Dubai cluster DXBA datacenter. We are investigating the incident and will provide an update as we make progress.
Posted Jul 14, 2026 - 08:33 UTC
This incident affected: Data Centers and PoP (Dubai (DXBA)).