Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 17, 2026 - 10:00 UTC
Scheduled
Forcepoint will be conducting a planned maintenance on our Cloud DSPM service on Monday, August 17th at 10:00 AM UTC for approximately 8 hours. The maintenance activity will involve deployment of the DSPM 4.1.3 Hotfix for further enhancing our services to provide improved performance and stability to our Cloud services.
The update will be applied on a rolling regional basis: US between 10:00 and 11:00 UTC APAC between 15:00 and 16:00 UTC EMEA between 17:00 and 18:00 UTC
We do not anticipate any service disruption during the maintenance window. No action is required from customers. Customer environments will be updated automatically.
We appreciate your understanding and cooperation as we continue to enhance our infrastructure.
Posted Aug 13, 2026 - 15:27 UTC
This scheduled maintenance affected: Services (Data Security Posture Management).