Email Security Cloud Service Performance Degraded

Incident Report for Forcepoint Cloud Status

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 19:11 UTC

Update

Customer Impact: We have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: Forcepoint has completed the required validation of the proposed solution from our vendor, and we can confirm that the encryption services are working optimally. Forcepoint has restored the encryption service in San Jose (Cluster G) data center, and are working on restoring services across all other clusters.
Posted Feb 17, 2025 - 17:44 UTC

Update

Customer Impact: We have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: Forcepoint continues to partner very closely with the Vendor on the provided resolution steps. Our QA validations and integration testing for the resolution has been completed, and we are proceeding ahead with performing a test in one of our production environments. We will provide further updates as we make progress.
Posted Feb 17, 2025 - 11:25 UTC

Update

Customer Impact: We have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: Our Vendor has identified a solution and Forcepoint is partnering with the Vendor to perform final validation against the proposed solution. We intend to roll out the fix across our production environment as soon as our testing concludes.
Posted Feb 16, 2025 - 16:52 UTC

Update

Customer Impact: We have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to partner with our vendor on the restoration of service. We will provide further updates as we make progress.
Posted Feb 13, 2025 - 03:23 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 11, 2025 - 09:41 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 10, 2025 - 09:14 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 07, 2025 - 16:05 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: Forcepoint has escalated the situation with our Vendor, and they continue to aggressively work towards a solution. We will provide further updates as soon as we have are made aware of an improvement from our vendor.
Posted Feb 07, 2025 - 09:09 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 07, 2025 - 08:14 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 06, 2025 - 16:03 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 06, 2025 - 08:36 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 06, 2025 - 07:10 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 05, 2025 - 22:46 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 05, 2025 - 20:07 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: Forcepoint has been notified by its Advance Encryption vendor that they have identified the problem and are actively working on implementing a remediation. We continue to follow up with our vendor for a resolution at the earliest.
Posted Feb 05, 2025 - 18:30 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We continue to work with our Vendor for the restoration of services. We will provide further updates as soon as we make progress.
Posted Feb 05, 2025 - 13:37 UTC

Update

Customer Impact: After further investigation, we have identified that Forcepoint's Email Security Customers who have purchased the Advanced Encryption service may experience a delay in sending and receiving securely encrypted emails from Forcepoint.

Current Status & Next Steps: We have identified the issue from the vendor side and are still actively working with our vendor to restore service as soon as possible.

Next update time: 11:00 UTC
Posted Feb 05, 2025 - 06:03 UTC

Update

Customer Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being quarantined and may need to release the emails. Customers who do not use our encryption service will not experience any impact on mail flow.

Current Status & Next Steps: We have identified the issue from the vendor side and are still actively working with our vendor to restore service as soon as possible.

Next update time: 10:00 UTC
Posted Feb 05, 2025 - 04:42 UTC

Update

Customer Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being quarantined and may need to release the emails. Customers who do not use our encryption service will not experience any impact on mail flow.

Current Status & Next Steps: We have identified the problem and are actively working with our vendor to restore service as soon as possible.

Next update time: 15:00 UTC
Posted Feb 04, 2025 - 13:36 UTC

Identified

Customer Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being quarantined and may need to release the emails. Customers who do not use our encryption service will not experience any impact on mail flow.

Description: We are currently experiencing a problem with our external email encryption provider due to which our email security solution is not able to receive an encryption or decryption token from our vendor. We are working with our vendor to restore service as soon as possible.

Next update time: 13:00 UTC
Posted Feb 04, 2025 - 11:41 UTC
This incident affected: Email Security Service (Heathrow (A), Frankfurt (B), Mumbai (C), Paris (D), Düsseldorf (E), San Jose (G), Ashburn (H), Slough (J), Sydney (M), Johannesburg (S), Singapore (R)) and Voltage Service (Global).