Forcepoint services have been fully recovered and We are currently monitoring our environment for stability,
Posted Oct 20, 2025 - 23:21 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 17:04 UTC
Monitoring
Forcepoint services have been fully recovered now and we are monitoring the situation closely. We are currently monitoring our environment for stability, and will provide a final update once we have confirmation on the same.
Posted Oct 20, 2025 - 11:49 UTC
Update
Amazon Web Services (AWS) is experiencing a major outage impacting availability of key AWS services in the US East region. For more details on the on-going AWS outage, please access AWS Staus page using the link below.
The on-going outage has unfortunately impacted some Forcepoint products which are dependent on AWS infrastructure and services. below is an update on the recovery of services:
1. RBI browsing services have fully recovered. Our synthetic monitoring indicate complete service restoration. 2. Access to Platform, and Insights Portal is also recovered. 3. FONE CASB service has recovered and access to managed application is restored.
What is currently impacted?
1. DPS continues to experiencing errors with scanning. 2. Mail-flow for DLP for Cloud Email is also impacted which might impact email delivery for some customers.
Forcepoint is monitoring the situation closely and we will update our customers on the recovery of services.
Posted Oct 20, 2025 - 11:18 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:07 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:01 UTC
Identified
Amazon Web Services (AWS) is experiencing a major outage impacting availability of key AWS services in the US East region. For more details on the on-going AWS outage, please access AWS Staus page using the link below.
The on-going outage has unfortunately impacted some Forcepoint products which are dependent on AWS infrastructure and services.
1. Remote Browsing Service is currently un-available. RBI customers may experience an error while trying to browse web content via RBI. 2. Access to Platform, and Insights Portal is currently impacted. 3. Access to managed applications via FONE CASB is impacted for customers in us-east region. 4. Customers with an active DPS license may experience errors with scan requests.
Forcepoint is monitoring the situation closely and we will update our customers if we identify any additional services being impacted.
Posted Oct 20, 2025 - 09:30 UTC
This incident affected: Management Console (Unified Platform), Services (Cloud Access Security Broker, Remote Browser Isolation, Email Data Loss Prevention, Data Protection Services), and Supporting Service (Insights).