Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being queued and re-attempted for delivery. Customers who do not use our encryption service will not experience any impact on mail flow.
Description: We have received an update from our Vendor about restoration of service from their end. Our internal monitoring suggests that our email relays are able to communicate with the Vendor's infrastructure. We continue to monitor the service for stability.
Posted Jul 05, 2025 - 11:19 UTC
Identified
Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being queued and re-attempted for delivery. Customers who do not use our encryption service will not experience any impact on mail flow.
Description: We are currently experiencing a problem with our external email encryption provider due to which our email security solution is not able to receive an encryption or decryption token from our vendor. We continue to work with our Vendor on restoration of Encryption services as soon as possible.
We will provide an update as soon as we have more information available to share.
Posted Jul 05, 2025 - 06:50 UTC
Update
Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being queued and re-attempted for delivery. Customers who do not use our encryption service will not experience any impact on mail flow.
Description: We are currently experiencing a problem with our external email encryption provider due to which our email security solution is not able to receive an encryption or decryption token from our vendor. We are in communication with our Vendor and they are looking into the event on priority.
We will provide an update as soon as we have more information available to share.
Next Update: 03:30 UTC
Posted Jul 05, 2025 - 02:23 UTC
Update
Impact: Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being queued and re-attempted for delivery. Customers who do not use our encryption service will not experience any impact on mail flow.
Description: We are currently experiencing a problem with our external email encryption provider due to which our email security solution is not able to receive an encryption or decryption token from our vendor. We are in communication with our Vendor and they are looking into the event on priority.
We will provide an update as soon as we have more information available to share.
Next Update: 01:00 UTC
Posted Jul 04, 2025 - 22:53 UTC
Investigating
Forcepoint's Email Security Cloud customers who use our Advanced Encryption service may experience that their secure emails are being queued and may re-attempted for delivery. Customers who do not use our encryption service will not experience any impact on mail flow.
Description: We are currently experiencing a problem with our external email encryption provider due to which our email security solution is not able to receive an encryption or decryption token from our vendor. We are working with our vendor to restore service as soon as possible.