Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 28, 2025 - 06:00 UTC
Scheduled
Forcepoint will be conducting a planned upgrade of its Data Protection Service hosted within AWS Middle East (UAE). The upgrade will start on Sunday September 28th at 06:00 AM UTC, lasting approximately 8 hours. Data Protection Service will be un-available for customers during the maintenance window.
This upgrade strengthens data protection requirements and ensures compliance with UAE regulatory requirements, providing customers operating in the region with enhanced control over critical data.
Please note only customers with a node in the UAE (Dubai) region are affected, and Forcepoint will notify the customers who will be affected separately with further details. Following this upgrade, affected customers will be required to update their DPS Connection details to take advantage of the upgraded infrastructure.
We apologise for any inconvenience this may cause and appreciate the cooperation.
Posted Sep 24, 2025 - 08:05 UTC
This scheduled maintenance affected: Services (Data Protection Services) and Data Centers and PoP (Bahrain (me-south-1), Dubai (me-central-1)).