Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 20, 2026 - 06:00 UTC
Scheduled
Forcepoint will be conducting a planned maintenance in our Dallas (Cluster-O) Datacenter on Saturday, June 20th at 06:00 AM UTC for approximately 8 hours. The maintenance activity will involve changes to enhance our network infrastructure further and improve the performance of our Cloud services.
We anticipate a brief loss of connectivity while customer traffic is failed over to an alternate data center. Customers are requested to ensure that they have redundant IPSEC and GRE tunnels configured to a redundant data center to ensure seamless failover of tunnel traffic.
We do not anticipate any service disruption during the maintenance window. We appreciate your understanding and cooperation as we continue to enhance our infrastructure.
Posted Jun 16, 2026 - 21:44 UTC
This scheduled maintenance affected: Data Centers and PoP (Dallas (O)).