RBI Service Unavailable - us-east-1 Region

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 15:00 UTC

Monitoring

Customer Impact: Some RBI customers in us-east-1 region may have experienced a loss connectivity while browsing the web via RBI.

Description: The fix has been implemented and we have started to notice early signs of recovery. We continue to monitor the service for stability.
Posted Apr 08, 2026 - 14:55 UTC

Identified

Customer Impact: Some RBI customers in us-east-1 region may experience a loss connectivity while browsing the web via RBI.

Description: We have identified the problem and are working on implementing the required remediation. We will provide further updates as soon as we make progress with the remediation efforts.
Posted Apr 08, 2026 - 14:50 UTC

Investigating

Customer Impact: RBI customers may experience a loss of connectivity while browsing the web via RBI in us-east-1 region.

Description: We are currently experiencing un-availability of RBI service in us-east-1 region. We are investigating the problem and will provide further update as make progress.

Next update time: 15:00 UTC
Posted Apr 08, 2026 - 14:36 UTC
This incident affected: Data Centers and PoP (N. Virginia (us-east-1)) and Services (Remote Browser Isolation).