DLP for Cloud Email - Email Delivery issue in ap-south-1 (Mumbai) Region

Resolved

This incident has been resolved.
Posted Apr 25, 2026 - 10:45 UTC

Monitoring

Customer Impact: DLP for Cloud Email customers in India region may experience email delivery failures with outbound emails. Impacted emails should get queued on customer's MTA for re-processing.

Description: We have started to notice recovery of services and we continue to monitor services for stability.

Next update time: 11:00 UTC
Posted Apr 25, 2026 - 10:32 UTC

Investigating

Customer Impact: DLP for Cloud Email customers in India region may experience email delivery failures with outbound emails.

Description: We are currently experiencing a problem with DLP for Cloud Email solution which is impacting outbound email delivery for customers in India region. We are investigating the problem and will provide further update once we make progress.

Next update time: 11:00 UTC
Posted Apr 25, 2026 - 10:16 UTC
This incident affected: Services (Email Data Loss Prevention) and Data Centers and PoP (Mumbai (ap-south-1)).