AMDP Cloud Analysis - Email Analysis and Delays for On-prem Email Security

Resolved

This incident is now resolved.
Posted Aug 01, 2025 - 16:35 UTC

Monitoring

Customer Impact: Some of our on-prem Email security customers may have experienced email delivery delays due to Advanced Malware Detection and Prevention malware analysis delays. The impact is restricted to on-prem email customers who leverage AMDP cloud in EMEA region. Email Security Cloud customers are not impacted due to this incident.

Current Status & Next Steps: Forcepoint has worked with the vendor and the vendor has implemented a fix to stabilise their databases to restore normalcy of services. We are currently monitoring our environment for stability, and will provide a final update once we have confirmation on the same.
Posted Aug 01, 2025 - 15:13 UTC

Update

Customer Impact: Some of our on-premises Email Security customers may experience delays in email delivery—specifically for emails with attachments—due to delays in Advanced Malware Detection and Prevention (AMDP) malware analysis. This impact is limited to on-premises email customers who utilize the AMDP cloud. Email Security Cloud customers are not affected by this incident.

Description: After confirming a resolution on their end, we received further updates from our Vendor that they continue to experience additional degradation in their EU region infrastructure which is contributing to a prolonged degradation of service. They have confirmed that a fix has been applied, and they are monitoring services for stability.

Forcepoint is following up with our Vendor ensuring that they deliver a solution at the earliest.
Posted Aug 01, 2025 - 12:00 UTC

Update

Customer Impact: Some of our on-premises Email Security customers may experience delays in email delivery—specifically for emails with attachments—due to delays in Advanced Malware Detection and Prevention (AMDP) malware analysis. This impact is limited to on-premises email customers who utilize the AMDP cloud. Email Security Cloud customers are not affected by this incident.

Description: Our vendor has confirmed that a resolution has been implemented on their end, and they are actively monitoring the stability of the service. Their systems are still processing a backlog of requests before full service restoration can be confirmed. We will provide further feedback as we make progress.
Posted Aug 01, 2025 - 00:48 UTC

Update

Customer Impact: Some of our on-prem Email security customers may experience email delivery delays (for emails with an attachment) due to Advanced Malware Detection and Prevention malware analysis delays. The impact is restricted to on-prem email customers who leverage AMDP cloud. Email Security Cloud customers are not impacted due to this incident.

Description: Our vendor has confirmed that they have implemented a resolution at their end and they continue to monitor the service for stability. Their systems are working through a backlog of requests before their service is back to its full health.

Next update time: 17:00 UTC
Posted Jul 31, 2025 - 15:11 UTC

Identified

Customer Impact: Some of our on-prem Email security customers may experience email delivery delays (for emails with an attachment) due to Advanced Malware Detection and Prevention malware analysis delays. The impact is restricted to on-prem email customers who leverage AMDP cloud. Email Security Cloud customers are not impacted due to this incident.

Description: We have identified the problem to be related to one of our malware sandboxing providers which is experiencing latency in responding to our request for file sandboxing. We are working with our vendor for a resolution at the earliest.

Next update time: 16:00 UTC
Posted Jul 31, 2025 - 13:39 UTC

Investigating

Customer Impact: Some of our on-prem Email security customers may experience email delivery delays due to Advanced Malware Detection and Prevention malware analysis delays. The impact is restricted to on-prem email customers who leverage AMDP cloud. Email Security Cloud customers are not impacted due to this incident.

Description: We are currently experiencing a problem which is impacting delivery of emails for on-prem email security customers. We are investigating the problem and will provide further feedback as we make progress.

Next update time: 14:00 UTC
Posted Jul 31, 2025 - 12:54 UTC
This incident affected: Supporting Service (Advanced Malware Detection and Protection).